
 

9What You Need to Get Going

                          
Chapter 2 GoLive CyberStudio 
QuickStart Guide
GoLive CyberStudio is a rich program with many features; the best 
way to learn about them all is to refer to the User Manual. However, 
GoLive CyberStudio also lets you accomplish many things without 
having to spend a long time with documentation. This QuickStart 
guide can’t replace the User Manual, but it will get you designing 
Web sites quickly.

Here’s what you’ll cover:

• creating pages
• adding content to pages, including text and graphics
• structuring your site
• linking
• previewing your work

What You Need to Get 
Going

Minimum System Requirements

1 A PowerMac (or equivalent) running Mac OS 7.5.5 or later

For Full Functionality

• QuickTime and QuickTime Power Plug, Versions 2.5 or later
• Sound Manager 3.1 or later 
• AppleScript, World Script, Scriptable Finder, and Apple Guide sys-

tem extensions
• SCLShared Lib, which GoLive CyberStudio automatically installs 

in your System Extensions folder; it cannot be moved to another 
folder

Installing GoLive 
CyberStudio

1 Insert the GoLive CyberStudio CD into your CD-ROM drive.

2 Double-click the installer icon.

3 Follow the instructions on the screen. When the installation is 
complete, copy contents of the Plugin folder for the browser 
you’ll be using to GoLive CyberStudio’s Plugin folder (which you’ll 
find in the same place as the GoLive CyberStudio application).



 

10 CHAPTER 2 Two Ways to Work

        
Two Ways to Work With GoLive CyberStudio, you can both create and manage Web 
pages. That means you can start either by blocking out the structure 
of a new site or by creating individual pages—or some combination 
of the two. You can move back and forth between these modes 
whenever you want.

Create a Whole Site: 
Working Top-Down

When you work top-down, you structure your site before creating 
content. For example, if you’re designing a personal home page, you 
probably already have a good idea of what to include: your resume, 
goals, and personal interests. You might then want to break these 
down further; your resume could include work history and samples 
of what you’ve done.

Working top-down with GoLive CyberStudio, you can insert place-
holders for all of these separate items. At any time, however, you can 
change your mind about what to include. You can also temporarily 
stop structuring your site and start adding content.

Creating Individual 
Pages: Working 
Bottom-Up

When you work bottom up, you build individual pages first and then 
organize them into a site. To continue with the personal home page 
example, you might want to lay out the first page, inserting text 
about who you are, graphics (like a photo of yourself), or multimedia 
elements (perhaps a clip from a favorite movie). At any time, you can 
stop working on one page and start another.

After you’ve created some pages, you’ll want to bring them together 
and insert links. GoLive CyberStudio will help you manage linking 
and also give you a snapshot of how the site looks.

To repeat, at any time you can switch from one style of working to 
the other.

How to Work in Quick-
Start

In this QuickStart guide, you’ll begin by working bottom-up and cre-
ate a personal home page. You’ll include text, graphics, and multi-
media, as well as identify the places on the page from which you’ll 
link to others. After you’ve created some content, you’ll switch 
modes and start thinking of the organization of the other pages that 
will make up the site.
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The Main Window Launch GoLive CyberStudio (and fill in your registration number if 
you haven’t already). GoLive CyberStudio opens in the Layout mode, 
where you’ll do most of your work:

Along the top of the window are tabs for GoLive CyberStudio’s differ-
ent modes:

• Layout, where you enter content and where you are when GoL-
ive CyberStudio starts

• Frames, where you create and manage frame sets
• Source, which shows you the HTML that makes up your page and 

which you can examine and edit
• Outline, which also shows your HTML but structures like an out-

line whose sections you can expand or collapse
• Preview, where you can see what your finished page will look like

At the bottom right of the window, you’ll see a popup menu where 
you set the width of your page.

Your First Page As with other WYSIWYG Web editors, GoLive CyberStudio will let you 
enter and format text just as you would with a word processor. Work-
ing that way, however, gives you very little control over where you 
can place objects.
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The Palette GoLive CyberStudio is much more than a word processor for HTML; 
you can also lay out your page with the precision of a desktop pub-
lishing program. That means you insert various objects—text, graph-
ics, and multimedia—exactly where you want them and get a good 
idea of how they’ll look in a browser. Better yet, you can preview 
multimedia objects like QuickTime movies and Java applets right in 
the Layout mode. You don’t have to use a browser.

In addition to the main window, when you launch GoLive CyberStu-
dio, it opens the Palette window, which looks like this:

The Palette contains icons for the objects you can place on your page. 
Click the Palette’s first tab (if it isn’t clicked already) to see the Layout 
objects. 

Here’s a key idea: You work with GoLive CyberStudio by dragging ob-
jects from the Palette and dropping them onto your page. 

The Layout Grid One of objects you’ll use often is the Layout grid (the second object 
on the Palette). Once the grid is on your page, you can place objects 
on it with one-pixel precision. The grid automatically expands to ac-
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commodate the size of the objects you place on it. You can also make 
it larger yourself by selecting it and dragging the appropriate handle.

You don’t have to use a single Layout grid for your entire page. Doing 
so, in fact, will create unnecessarily large HTML files. Instead, you can 
mix-and-match Layout grids and normal HTML or even use several 
small Layout grids on the same page. That will give you both design 
flexibility and smaller HTML files.

Let’s start by putting some text and a horizontal rule on the page:

1 Go to the Palette and locate the Layout Grid icon.

2 Hold down the mouse button and drag the Layout grid icon to 
your page.

Release the mouse button. The grid is now on your page something 
like this: 

3 To repeat, what you’ve just done is the basic method for inserting 
objects into your page: Locate an object on the Palette and drag 
it to where you want on your page.

Now add text:

4 Go back to the Palette and locate the Text Box icon.

5 Hold the mouse button down and drag the Text Box icon onto 
your grid. Position it at the top to act as the main heading.

6 Place the cursor within the text box.

7 Enter “My Home Page.”



 

14 CHAPTER 2 The Layout Grid

                 
Here’s what the page looks like (more or less):

You’ll want to better position the text box and make “My Home Page” 
bold, larger, and properly aligned. Here’s how:

1 Select the Layout grid by clicking one of its edges; handles appear 
on the bottom and on the right side.

2 Drag the handles to stretch the grid over the width of the win-
dow. 

3 Select the Layout text box by clicking one of its edges; handles ap-
pear on the bottom and on the right side. 

4 Drag the handles until the Layout  text box is about the same 
width as the Layout grid. 
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5 If you need to reposition any object, de-select it and move the 
cursor to any one of its edges. The cursor turns into a hand. Hold 
the mouse button down and drag the object box to where you 
want it.

6 Select the text “My Home Page” in the usual Mac way.

7 Go to the Style menu and choose Bold.

8 Go to the Style menu and choose Size, then 7.

9 Go the Format menu and choose Alignment, then Center.

Instead of using menus, you could have made the same changes 
with the icons on the toolbar—for example, by choosing  for 
Bold,  for Size, and  for center alignment.

Now let’s add a horizontal rule:

1 Go back to the Palette and locate the Horizontal Rule icon.

2 Hold the mouse button down and drag the Horizontal Rule icon 
onto your grid. 

3 Position it just under the text.
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Your screen should look something like this:

The Color Picker Before we add other objects, let’s add color to what we already have. 
We’ll change the colors of both the background and the text we’ve 
entered. Once again, we’ll use drag & drop, but this time for the Color 
Picker, which looks like this:
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The Color Picker has seven palettes; the default is the System palette 
(selected here); it’s always wise to use either of the two browser-safe 
palettes that will keep your colors consistent across platforms. 

To change your page’s background color:

1 Go to the Window menu and choose the Color Picker (if it isn’t 
opened).

2 Go to the Color Picker and click on a color to select it. The color 
will appear on the Color Preview Pane in the upper part of the 
Color Picker.

3 With the mouse button up, move the cursor to the Color Preview 
Pane.

4 With the mouse button down, drag the color from the Color Pre-
view Pane to the Page icon  at the upper left corner of the Layout 
window.

5 When the Page icon highlights, release the mouse button and the 
background color changes.

To change text color:

1 Select the text “My Home Page.”

2 Go to the Window menu and choose Color Picker (if it isn’t 
opened).

3 Go to the Color Picker and click on a color to select it. The color 
will appear on the Color Preview Pane in the upper part of the 
Color Picker.

4 Move the cursor to the Color Preview Pane.

5 With the mouse button down, drag from the Color Preview Pane 
to the selected text. 

6 Release the mouse button and the text color changes.
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The Inspector You can continue adding objects to your page, but before that, you’ll 
need to know how to examine and change the attributes of the ob-
jects you insert. You do that with the Inspector, a context-sensitive 
window whose information changes depending on what you have 
selected at any given time. 

To use the Inspector:

1 Go to the Window menu and choose Inspector.

2 Click on the Page icon in the upper left corner. The Inspector’s 
name changes to Page Inspector and looks like this: 

Here you see information about your page—for example, its default 
color for text and links. You can also see the background color for 
your page. You can change any of these colors from here by clicking 
on the small color preview panes beside each attribute: The Color 
Picker  module opens and you choose a new color.

To see that the Inspector is truly context sensitive, go back to your 
page and click on the horizontal rule to select it. The Inspector 
changes to the Line Inspector and looks like this:

Enter various values into the Width and Height boxes; GoLive Cyber-
Studio updates the Layout window immediately. 
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The Inspector is one of the key features of GoLive CyberStudio: it al-
ways displays information about the object you have currently se-
lected.  So rather than having to click through a series of menus and 
sub-menus to change the attributes of an object, you can rapidly 
make changes via the Inspector.

Inserting Graphics You also use the Palette and the Inspector together to insert and ad-
just graphics. GoLive CyberStudio assumes that you have already cre-
ated the graphics you’ll need in some other application. Here’s how 
to insert them:

1 Go to the Palette and locate the Image icon.

2 Drag it to the location on the grid you want. (If you are not using 
the Layout grid, the Image icon will appear at the current loca-
tion of the cursor.)

3 Select the Image icon on your page.

4 Open the Inspector; it is now titled the Image Inspector and dis-
plays a series of tabs.

5 Select the Basic tab. The Source Field will show “Empty Refer-
ence” because you have not yet selected the graphic to insert 
here.

6 Click Browse. A file selection dialog box will open.
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7 Navigate to the file you want and click Open. The Image icon will 
be replaced by your graphic.

You also could have typed the pathname and filename; however, it’s 
simpler to let GoLive CyberStudio do the work.

Adjusting Your 
Graphic

The Image Inspector lets you change various attributes of your image. 
The Basic tab has fields for your graphic’s height, width, and align-
ment. Other tabs have fields for alternate text, border width, creating 
links, and making the graphic into a client-side image map. Experi-
ment with the other settings.

Other Objects You Can 
Use

Move your mouse over the Palette’s objects; at the bottom of the Pal-
ette window, you’ll see the name of each one. These include:

• icons for anchors
• JavaScripts
• new HTML tags that GoLive CyberStudio doesn’t yet know about
• comments
• spacers
• frames

Experiment with them if you wish, although you should refer to the 
GoLive CyberStudio User Manual for these features.

Saving Your Work As with most other programs, GoLive CyberStudio does not automat-
ically save your work. It’s good practice to periodically do so yourself 
and avert potential data loss.

When you do save your pages, remember to give them names that 
can be recognized by the platforms you expect to use, either for serv-
ing or viewing pages. For example:

• DOS-based machines can handle only up to  eight characters in 
their names, plus three more in their extensions (like 
mypage.htm). 

• UNIX machines won’t accept names with any blanks or spaces.
• To ensure your pages have the extensions necessary for UNIX or 

Windows servers:
1 Go to the Edit menu and choose Preferences.

2 Select the Project icon. (You may have to scroll to make it visible.)
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3 In the HTML files are files with section, click the Filename Exten-
sion “html” or “htm” or “Both” radio button.

4 Click OK to confirm your selection.

GoLive CyberStudio appends the default extension to your filenames 
when you save them.

The Project Window: 
Gathering and Storing 
Resources

To this point, we’ve worked with just a single page that included text, 
graphics, and multimedia. As you add more pages and objects to a 
site, you can easily lose track of the resources you use. GoLive Cyber-
Studio’s Project window helps you see what you’re using.

To show you how this works, you first need to save the page you’ve 
been working on to the folder you’ll use for the site you’re building. 
Here’s how:

1 Go to the File menu and choose Save. 

2 In the subsequent dialog box, create a new folder (call it Quick-
Start Test Site).

3 Save the page you’ve been working on as welcome.html

4 Close the page.

Now you’re going to create a project window and store all your re-
sources there—including new pages, multimedia objects, and 
graphics.

Creating a Project 1 Go to the File menu and choose New Project.

2 Name the project something like QuickStart.Project.

3 Save it in the same folder where you saved welcome.html.
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The Project window will appear on your screen:

The Project window is empty for the moment, even though you’ve al-
ready saved your first page. To tell GoLive CyberStudio you want to 
use that page in this site:

1 Go to the Finder.

2 Locate and open the QuickStart folder.

3 Locate the welcome.html icon and drag & drop it into the Project 
window.

4 Go back to GoLive CyberStudio.

5 Select the Pages tab (if it isn’t already selected).

welcome.html is now part of the project.

The Project window is a key element in GoLive CyberStudio: It’s the 
container where you  store references to everything you need to cre-
ate a site (such as pages, graphics, and movies). You can use an alias 
of an object rather than a copy and so avoid needless duplication.

You could leave files where they happen to be on your hard drive; 
GoLive CyberStudio will still keep track of them. However, there are 
some important reasons to store references in the Project window:

• You can use GoLive CyberStudio’s Point & Shoot to link them to 
other objects.

• You avoid the potential problem of losing track of your 
resources.
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Adding Pages to the 
Project Window

To make sure that all new pages are automatically added to the 
Project window, set a GoLive CyberStudio preference:

1 Go to the Edit window and choose Preferences.

2 Locate the Project icon on the left side of the Preferences dialog 
box. (If it isn’t visible, scroll to it.)

3 Check the box labeled Automatically add new documents.

Whenever you’re working on this project, all the pages you save will 
automatically be added.

Adding Other Media 
to the Project Window

As we’ve said, the Project  window stores references (or aliases or 
bookmarks) to the resources you need for your site. Let’s see how this 
works with objects other than pages:

1 Copy any graphic file to the QuickStart Site folder.

2 With the Project window open, click on the Media tab.

3 Drag & drop the graphic file from the Finder to your page. The 
graphic file will be listed in the Project window.

4 Click the Pages tab.

5 Double-click the welcome.html icon. The page will open.

6 Put the cursor somewhere on the page’s Layout grid.

7 Go to the Project window and click on the Media tab.

8 Drag & drop the graphic’s icon to your page. The graphic will ap-
pear on the page.

You could have entered the graphic as you did previously, that is, by 
using the Graphic icon from the Palette. GoLive CyberStudio gives you 
several ways to perform many operations, but using the Project win-
dow to insert objects is particularly convenient. You can use the 
same technique for other objects as well.

Identifying the Home 
Page

Every site must have a home page, that is, the page that  site visitors 
first see. From there, they can link to other pages. Here’s how to tell 
GoLive CyberStudio what to use as your home page:

1 Open the Project window and select welcome.html.

2 Open the Inspector, now titled the Reference Inspector. Note that 
the name field displays the name of the page, welcome.html.

3 Select the Page tab (if it isn’t already selected).

4 Locate the Home Page checkbox (in the lower half of the Refer-
ence Inspector) and click on it.
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5 In the Project window, welcome.html is now set in bold type to 
indicate it’s the home page.

6 Go to the Project menu and choose Show Site. You’ll see wel-
come.html.

The Site View gives you a picture of your site, a way to add to it, and 
a way to structure it. Right now, there’s only welcome.html, but you’ll 
add more.

Building Your Site 
with Site View

You’re now going to switch modes and work top-down, that is, you’re 
going to decide what pages your site will have and then return later 
to add content to them. Although you’ll be adding placeholders for 
pages, you can change your mind any time about what should go 
where.

Suppose you want your site to show visitors your resume, your career 
goals, and your interests. Suppose again that under your resume you 
wanted additional pages for your work history and some samples of 
your work. Here’s how to add placeholders for those pages.

In the Site View window:

1 Select the home page (that is, welcome.html).

2 With the mouse button down, press and hold the Option key.

3 Drag the welcome.html icon downward a few inches.

4 Release the mouse button.

GoLive CyberStudio has created a new page icon, titled New 1.1., that 
is the “child” of welcome.html. Remember that it is not yet a real 
page but simply a placeholder. Repeat these steps twice more, so 
that you have the welcome.html and three other pages, all children 
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of welcome.html and siblings of each other. Your screen should look 
something like this:

You now have a snapshot of the site and can see how the four pages 
will be related.

Because you want to have two separate pages that will be subpages 
of the resume, you can create them here. 

In the Site View window:

1 Select the page that you’ll use for your resume (here New 1.1).

2 With the mouse button down, press and hold the Option key.

3 Drag the New 1.1. page downward a few inches.

4 Release the mouse button.

5 Repeat Steps 1 to 4 to create another child of New 1.1.
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Your screen will look something like this:

You could continue adding, re-arranging, or deleting placeholders 
for pages that are “generic” (that is, they have no content and are not 
part of your project until you save them). This gives you a chance to 
work top-down and plan your site.

But switch modes once again, add some content to these pages, give 
them permanent names, and save them:

1 In the Site View window, double-click New 1.1. It opens for edit-
ing.

2 As you did with welcome.html, add some content about your re-
sume (contact information, for example) and a header that will 
immediately tell your visitor about the page. Keep your text brief 
for now.

3 When you’re done adding content, rename the page as Re-
sume.html in the Image Inspector.

4 Repeat with New.1.2, adding content for Goals.

5 When you’re finished adding content, rename the page as 
Goals.html.

6 You will then want to drag the files from the GenericPages folder 
within the Project window.
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Linking Pages You now have a series of pages with varying amounts of content, but 
as yet, there’s no way that a site visitor can get from one to the other. 
The next thing to do, therefore, is to add some links.

GoLive CyberStudio provides a number of ways of linking, and we’ll 
use two of the most common ones. First, however, you have to create 
the text that site visitors will click on to go to another page:

1 Go to the Project window, locate the welcome.html icon, and dou-
ble-click. The page opens for editing.

2 Go to the Palette, locate the Layout Grid icon, and drag it to the 
page.

3 Go to the Palette, locate the Text Box icon, and drag it to the page.

4 Place the cursor in the text box (it will change into an I-Beam) 
and enter  “Resume” and “Goals,” each on a separate line. 

Linking with the 
Project Window

Here is the first way to create a link:

1 If welcome.html isn’t open, go to the Project window and open it.

2 Select “Resume” so that it’s highlighted.

3 Open the Project window and locate and select the resume.html 
icon.

4 Holding down the mouse button, drag the resume.html icon from 
the Project window until it’s over the text “Resume” on your page.

5 Release the mouse button; “Resume” will be linked.

Here is the second way to create a link:

1 If welcome.html isn’t open, go to Project window and open it.

2 Select the text “Goals.”

3 Go to Project window and the open goals.html. You now should 
have two pages open.

4 Click on goals.html so it’s the frontmost window. 

5 Go to the Page icon on goals.html.

6 Holding down the mouse button, drag the Page icon from 
goals.html until it’s over the text “Goals” on welcome.html.

7 Release the mouse button; “Goals” will be linked.

Linking from a 
Graphic

In addition to linking from text, you can also link from a graphic. 
Here’s how:

1 Open welcome.html and locate the graphic you inserted earlier.



28 CHAPTER 2 Previewing Your Work
2 Select the graphic. The Inspector  is now titled the Image Inspec-
tor.

3 In the Image Inspector, click the Link tab.

4 Select the New Link  icon.

5 The URL field will show “Empty Reference” because you have not 
yet selected a filename to insert there.

6 Click Browse. A file selection dialog box will open.

7 Navigate to the file you want and click Open. GoLive CyberStudio 
will insert the file’s name into the URL field.

When site visitors click the graphic, it will take them to the second 
page.

Previewing Your Work Now that the links are in place, you’ll want to test them. You do that 
either with GoLive CyberStudio’s Preview mode or with your browser.

To use GoLive CyberStudio’s Preview mode:

Open the page you want to preview—in this case, wel-
come.html.

8 Locate the Resume link, just as you would in a browser. The cur-
sor turns into a hand when you are over the link.

9 Click the link and Resume.html opens in a new window.

To use a browser:

1 Go to the File menu and choose Preferences.

2 Select the Browser icon (if it isn’t visible, scroll to it).

3 In the Browser settings, you can click Add and then manually se-
lect the browser you want. Or you can click Find All and let GoLive 
CyberStudio automatically find all the browsers installed on your 
hard drive.

4 If you have more than one browser, click to the left of the one 
you wish to be the default. Click OK. You don’t have to repeat 
these first four steps, unless you want to change default brows-
ers. 

5 Close the Preferences dialog box to return to your page.

6 Locate and click the Show in Browser icon at the extreme right of 
the toolbar. (The icon varies with each browser.) Your browser 
will launch and display your page.

7 Locate the Resume link on the browser’s display.
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8 Click the link and Resume.html opens in the same window.

Because browsers and platforms all do things their own ways, a page 
that looks fine on one system can look terrible on another. It’s always 
a good idea to try out your pages on as many different browsers and 
platforms as you can. 

Summing Up In this QuickStart guide, you’ve done the following tasks:

• created pages
• added content, including text and graphics
• added new pages and structured your site
• made links
• previewed your work

Once you’re comfortable with the material in this QuickStart guide, 
you’ll want to learn how to upload your site to a Web server, use 
frames, insert QuickTime movies and Java applets, write JavaScripts, 
and much more. The User Manual remains your best guide to GoLive 
CyberStudio’s many features. 

There’s much more to know about Web design, of course, and you 
may want to read one of the many books on the subject. David Sie-
gal’s Creating Killer Web Sites: The Art of  Third Generation Site Design 
(Hayden Books, 1996) is a good place to start.
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